Unable to copy & paste


I’ve just build nyxt from source (32efb49e4) but I’m unable to copy & paste

Warning: Error on seperate thread: The value "wl-copy"is not of type LIST

I’m using Arch Linux, sbcl 2.3.8, StumpWM, not sure why it tries to use wl-copy

Did you use the git submodules when building? There should be a new version of trivial-clipboard that handles both Wayland and X11 clipboards. I can only suggest you install the flatpak instead :smiley:

I’ve installed the precompiled nyxt package via pacman, which works fine.

Btw is there a way to define the path for sly? Using start-slynk in the precompiled Arch version fails to connect, it’s looking for /build/nyxt/src/_build/ which does not exist.

I’ve created /build/nyxt/src and copied the _build dir there, but it’s a hacky solution.

Extra: I’m really enjoying my first hours with nyxt, thank you for making this

@thanosapollo the clipboard issue has been fixed on version 3.6.1. Arch is still on 3.6.0 so please ask the maintainers to update the package.

Regarding start-slynk, the best solution as of today would be for Arch to package cl-slynk and add it as a dependency for Nyxt. This is how it works on Guix. Notice that we officially maintain the distribution of Nyxt on Guix, while the Arch packing effort is done by volunteers so we can’t guarantee its quality. Nonetheless, we’re thinking about a more general alternative. Thanks for sharing the temporary hack to fix it!

@aadcg Apologies, I did not give a proper explanation

The clipboard issue I mentioned above occurred while building nyxt via git and the nyxt-git package(both result in the clipboard issue). This problem persisted on both my desktop and my thinkpad.

However, I did not experience any clipboard issues when using version 3.6.0 from pacman.

I haven’t tested building version 3.6.0 yet to check if it’s specific to my configuration/setup or it has something to do with the new version, but I can do it tomorrow if you’d like.

sidenote: Guix is awesome!

Ups, my mistake. You do mention on the top post that you’re building from source.

From where you start Nyxt, could you please run env | grep XDG_SESSION_TYPE and report the result?

I’m glad you’re enjoying Nyxt. If you can run it from Guix, that would be ideal since we test it systematically.

(standard input):XDG_SESSION_TYPE=tty

I’ve build stumpwm from source and launch it via xinit/startx as they recommend on their site

It would be ideal even for me to daily drive guix, but last time I tried it didn’t go so well, had a couple of issues with nonguix and finding some packages that I require for daily use, would love to try it again sometime in the future, thanks for making it’s ecosystem better.

Bingo! Could you run export XDG_SESSION_TYPE=x11 and start Nyxt? Is the clipboard issue gone?

Regarding Guix, I can suggest installing it on top of another distribution (as an additional package manager). If you’d like to run it as a distribution, you can always install missing packages from Flathub (Flatpaks).

Nope (tried from git and nyxt-git, it would have been a nice catch tho!)

Are you using Guix as a daily driver? Debian seems to have decent support for guix oob but Arch not so much

If you’re running from source, can you run git status at /path/to/source/_build/trivial-clipboard?

By the way, did you start Nyxt from the same shell where you run export XDG_SESSION_TYPE=x11?

My bad, had to restart my session(I was using eshell), it works now!

Have a nice day and thanks for the support!

Exactly what I thought! I tend to know when I hit bingo :slight_smile:

Thanks for this report. We’ll fix it. For the time being, I suggest adding this to your ~/.profile or creating a script that exports the variable and starts Nyxt.

1 Like

Are you using Guix as a daily driver? Debian seems to have decent support for guix oob but Arch not so much

I run Guix as a distribution. I never used it as an additional package manager but I don’t think the distribution matters much. The install script seems to be general enough. Installing Guix it from, say, pacman or APT would be cleaner though, especially for uninstalling.