Opening url from terminal fails. Error on seperate thread

Hi, I am trying to control nyxt from a terminal.
In my config I have this;

(define-configuration browser
   (remote-execution-p t)))

nyxt -r -q -e '(make-window (make-buffer :url “”))'
[13:42:39] Probing remote instance listening to /run/user/1000/nyxt/nyxt.socket.

Console says:

<INFO> [13:42:39] External evaluation request: "(make-window (make-buffer :url “”))"
<WARN> [13:42:39] Warning: Error on separate thread: Package “HTTPS does not exist. Stream: #&lt;dynamic-extent STRING-INPUT-STREAM (unavailable) from &quot;(make-wi...&quot;&gt;

I can’t reproduce.

What’s the output of nyxt --system-information? How did you install Nyxt?

I think I installed from aur. I tried guix but it had very old version and I couldn’t figure out how to update it.

Nyxt version: 3.9.0
Renderer: GI-GTK
Operating system kernel: Linux 6.5.7-arch1-1
Lisp implementation: SBCL 2.3.8 (Dynamic space size: 3221225472)
:GTK-3-14 :GTK-3-12 :GTK-3-10 :GTK-3-8 :GTK-3-6 :GTK-3-4 :GTK :GDK-3-22
:GDK-3-20 :GDK-3-18 :GDK-3-16 :GDK-3-14 :GDK-3-12 :GDK-3-10 :GDK-3-8 :GDK-3-6
:GDK-3-4 :CAIRO-1-10 :CAIRO-1-12 :GDK-PIXBUF :CLOSER-MOP :GLIB-2-30 :GLIB-2-32
:GLIB-2-34 :GLIB-2-36 :GLIB-2-38 :GLIB-2-40 :GLIB-2-42 :GLIB-2-44 :GLIB-2-46
:GLIB-2-48 :GLIB-2-50 :GLIB-2-52 :GLIB-2-54 :GLIB-2-56 :GLIB-2-58 :GLIB

ASDF version: 3.3.1
Critical dependencies: (/build/nyxt/src/_build/cl-cffi-gtk/gtk/cl-cffi-gtk.asd

Guix version:

I have no clue honestly. Arch’s distribution of Nyxt isn’t maintained by us. This does work properly on Guix.

Try to gather more information by evaluating other commands.

As a test I tried

(copy-to-clipboard (render-url (url (current-buffer))))

That worked. I also tried
nyxt -r -q -e '(make-window (make-buffer ))'
And that opens a new nyxt window with whats looks like the same state as original. I assume that is the expected behaviour for that.

It is indeed. Are you sure that you’re typing nyxt --remote --quit --eval '(make-window (make-buffer :url ""))'? I see some weird quotes in your version. Copy from my message.

Ok great, that fixed it. I thought I was going mad… actually, maybe I am… I don’t think I ever knew there where two types of double quotes in the world, the normal one " and this other one “ . It took me a while to spot that difference! Thanks for your patience.

1 Like