Issues with building from source- Blank Screen

Hey, I tried to build nyxt from the source code (first by downloading the tarball, then by directly cloning into gitHub). each time, the build is successful (once i have added
DESTDIR ?= /usr/bin/ PREFIX ?= /usr/bin/ NASDF_SOURCE_PATH ?= /usr/lib/
to the makefile).

However, when I run nyxt, i get a blank screen and the warning
Warning: Error on separate thread: There is no applicable method for the generic function #<STANDARD-GENERIC-FUNCTION NYXT:CERTIFICATE-EXCEPTIONS (1)> when called with arguments (#<NYXT/MODE/CERTIFICATE-EXCEPTION:CERTIFICATE-EXCEPTION-MODE {100FC5E653}>). See also: The ANSI Standard, Section 7.6.6

Ive tried switching between gi-gtk and gtk in the make file, ive tried building from 3.9.2 instead, and Ive built from both a cloned git repo and the tarball, and I keep having this problem.

Im currently running on AntiX (basically, debian minus systemd) on a lenovo thinkpad t440 if thats of any use. Ive tried using the flatpak, and the flatpak works, but I really dont like flathub. Ideally, if there was a .deb file, id have downloaded and ran from that.

Any Advice? I have full logs from my last build; id post all of them if it would be helpful.

What WebKitGTK version are you using? Note that the required shared library is

realized i was using webkit2gtk-4.0 (debian repos seem to only have it in unstable). updated to webkit2gtk-4.1 and im getting the same error.

Please share the output of nyxt --system-information.

nyxt --system-information
Nyxt version: 4
Renderer: GI-GTK
Operating system kernel: Linux 5.10.142-antix.2-amd64-smp
Lisp implementation: SBCL 2.1.1.debian (Dynamic space size: 3221225472)
 :WEBKIT2-SANDBOXING :GTK-3-22 :GTK-3-20 :GTK-3-18 :GTK-3-16 :GTK-3-14
 :GTK-3-12 :GTK-3-10 :GTK-3-8 :GTK-3-6 :GTK-3-4 :GTK :GDK-3-22 :GDK-3-20
 :GDK-3-18 :GDK-3-16 :GDK-3-14 :GDK-3-12 :GDK-3-10 :GDK-3-8 :GDK-3-6 :GDK-3-4
 :CAIRO-1-10 :CAIRO-1-12 :GDK-PIXBUF :GLIB-2-30 :GLIB-2-32 :GLIB-2-34
 :GLIB-2-36 :GLIB-2-38 :GLIB-2-40 :GLIB-2-42 :GLIB-2-44 :GLIB-2-46 :GLIB-2-48
 :GLIB-2-50 :GLIB-2-52 :GLIB-2-54 :GLIB-2-56 :GLIB-2-58 :GLIB :NYXT-4

ASDF version: 3.3.1
Critical dependencies: (/home/tara/nyxt/_build/cl-cffi-gtk/gtk/cl-cffi-gtk.asd


@storm-crow thanks. I think the issue is that you're using a rather old release of SBCL. The latest release is 2.4.1.

Thanks for pointing that out. I just updated sbcl.
Apparently, when i tried to download the newer version of libwebkit2gtk off of SID, a bunch of other packages started breaking dependencies (a lot of them related to ghc and OCaml and stuff). in addition, git just kind of stopped working as well, and theres some sort of filetrace error in apt. Reinstalled git, trying again with qt or gtk to see if things work, if not, i will redownload all the gl-gtk library stuff to see if it works.

At the very least, trying to download custom software on a smaller distro, getting stuck in dependency and update hell, and editing makefiles by hand is a very good educational experience for linux.

used GTK rather than gi-gtk. redownloaded all the libraries.

updating to sbcl 2.4 seems to be enough.

using the libweb2gtk-4.0 gives a few errors about video codecs on the terminal, but it works!

Nice :slight_smile: glad that you got it working! Probably not the most optimal experience as it is, but a good first!