Nyxt newbie, some initial thorns, thougts, and questions

I would like to start out by saying how excited I am about Nyxt and have been tracking it for a while, and have finally started to take the plunge. During this plunge however I’ve come across some hitches which I would like to go over, as some of them managed to shut me down for a day.

I should preface this by also mentioning that I’m operating on vim-bindings throughout my experience.

Unclear whether or not text-input field is focused: One of the first sites I went to was GitHub, and I hit a pretty significant blocker upon trying to sign in: I couldn’t enter my username! To be exact, I typed the first two letters in fine, but on the third (an “m”) it would always activate the mark command. Of course after a good deal of confusion I realized that I needed to enter the text field through the f command (or slamming the tab key), where everything then worked perfectly.

Long response times for menus/commands: It has been pretty frequent that whenever i execute a command, it sometimes takes 1 to several seconds for the dialog/menu on the bottom to pop up, often long enough for me to wonder if I hit the right keys! I don’t know if this is normal or perhaps due to some default setting? I’ll give that I’m not on the newest hardware, but I can survive with 3 electron apps and more online, so I really need to doubt its a spec issue. If it is a default setting (perhaps waiting for some other input), what might I change?

Perceived breakage on initial session: This one is by far the most dubious, so at best I’d like to provide a single anec-datapoint. When I entered my first session with Nyxt and was brought to the initial hello/tutorial/setup page (and I actually think I may have been in the default keybinds at this moment), it felt like none of the keybinds were actually working. I recall looking at the introductory material, which said the bind C-h C-h would trigger the help command, yet hitting those keys produced no result (and yes, I know C-h means Ctrl-h, so it wasn’t that). I had tried swapping bind-layouts and eventually just closed and reopened Nyxt, which is when it felt like things were working again.

EDIT: In case the information is important, I’m running version 2.0.0 downloaded from the AUR, on Garuda Linux

Hello welcome to the wonderful world of Nyxt! I don’t know how much help I can be if this doesn’t help but the standout bit from your message is that your version is old. Any specific reason for that? Looks like AUR has an up to date version. AUR (en) - nyxt

While mine isn’t from AUR (Ubuntu here… for now…) I was having some similar issues (especially for load times) when I was on 2.0.0, maybe try updating?

As for the keybindings I don’t use vim or have insight there but I expect that won’t be fixed with updating.

Appreciate the alert on the version! No idea how I got to that to be honest, after a reinstall I seem to be on the newest version. Unfortunately I’m still encountering the long load-times :-(, even for just hitting the f key, takes +1 second for the prompts to show up even on a page with 3 elements :-/