Installation workaround

After purchase, demeter was deliver as a tar.gz file. Copying the extracted folder Demeter into the directory ~/.local/share/nyxt/extensions according to the installation hint was not sufficient to get demeter active. I added the Demeter folder to my ASDF registry by adding (:directory (:home ".local/share/nyxt/extensions/Demeter")) to ~/.config/common-lisp/source-registry.d/asdf.conf and adding (asdf:operate 'asdf:load-op 'demeter) to ~/.config/nyxt/init.lisp.


Thanks for the tip! I may have done something wrong but after following the steps you listed I get the message:

Could not load the init file: Component ASDF/USER::FEEDER not found, required by #<SYSTEM "demeter">

when starting up Nyxt.

Any ideas as to what could have gone wrong?

Hm, I will definitely put that in the readme, thanks for the heads up! I think it has to do with the version of Nyxt you are using.

@ambrevar, any ideas?

In my demeter package, feeder is located at ~/.local/share/nyxt/extensions/Demeter/_build/feeder, hence it is found in the ASDF registry by the (:directory ... clause as above.

If feeder is not in your demeterpackage, you may want to load it withquicklisp, as it is the shinmera/feeder` (afaik / nyxt 2.2.1).

feeder should automatically be downloaded (if your Demeter is recent enough, i.e. after commit 0e7c59ac4275869e927ed7d2853c44b15d50883e).

That is, unless you’ve set the NYXT_SUBMODULES environment variable to false.

@fbmnds Can you report what (uiop:getenv "CL_SOURCE_REGISTRY") returns in a lisp-repl (from within Nyxt)?

> (uiop:getenv "CL_SOURCE_REGISTRY") /home/dev/.local/share/nyxt/extensions/Demeter/_build//:/home/dev/.local/share/nyxt/extensions/Demeter/:

Sorry, I meant asdf:*default-source-registries*.

asdf:*default-source-registries* is empty

That’s your problem, it should have nyxt-source-registry at least.
Are you customizing this symbol somewhere, maybe in your init file?

With nyxt 2.2.2 (deb), asdf:*default-source-registries* contains nyxt-source-registry as expected.

How did you install Nyxt 2.2.1?

I used the Derbian package. Note that I do not have SBCL preinstalled as I am using mainly CCL.

This is odd, maybe something is off in your settings because nothing related to the source registries changed between 2.2.1 and 2.2.2.
Anyways, glad to see it now works for you! :slight_smile:

1 Like