How to get rid of bottom buffer on startup?

When I launch Nyxt I always get a buffer on the bottom asking which session I want to restore. How do I get that to go away without restoring a session? I’ve tried C-g, not inputing anything, inputing nil and 0 but they all still restore the previous session. Also, I am looking to rebind a lot of keys that use f1 since my WM setup uses that. So can anyone give a link to their config or an example one? Couldn’t find a ton of results when I looked it up.

Here’s the code snippet to disable session restoration:

(define-configuration browser
  ;; This is for Nyxt to never prompt me about restoring the previous session.
  (#+nyxt-2 (session-restore-prompt :never-restore)
   #+nyxt-3 (restore-session-on-startup-p nil)))

And then look at Configuration Expose part of this forum to find the links to lots of configuration repos :slight_smile:

1 Like

Note that on 3.* Nyxt restores the last active session, without prompting you on which one to use. So the stuff’s gotten slightly more comfortable :smiley: