Flatpak not run Nyxt 3 pre-release 5

Firstly, my configuration:

Operating system kernel: Linux

Secondly, my way to install Nyxt 3 pre-release 5:

1/ wget nyxt.flatpak from github.com
2/ sudo flatpak install nyxt.flatpak

***** Messages during the installation: *****

Required runtime for engineer.atlas.Nyxt/x86_64/master (runtime/org.gnome.Sdk/x86_64/42) found in remote flathub
Do you want to install it? [Y/n]:
Info: org.gnome.Sdk//42 is end-of-life, with reason:
The GNOME 42 runtime is no longer supported as of March 21, 2023. Please ask your application developer to migrate to a supported platform.

engineer.atlas.Nyxt permissions:
network cups fallback-x11 pulseaudio wayland x11
dri file access [1] dbus access [2]

[1] xdg-cache, xdg-config, xdg-documents, xdg-download, xdg-music, xdg-pictures, xdg-videos
[2] org.a11y.Bus

    ID                                          Branch         Op         Remote              Download
  1. [✓] org.freedesktop.Platform.GL.default 21.08 i flathub 129.5 MB / 129.8 MB
  2. [✓] org.freedesktop.Platform.openh264 2.0 i flathub 1.8 MB / 1.5 MB
  3. [✓] org.gnome.Sdk.Locale 42 i flathub 63.1 MB / 342.0 MB
  4. [✓] org.gnome.Sdk 42 i flathub 672.5 MB / 586.1 MB
  5. [✓] engineer.atlas.Nyxt master i nyxt-origin 0 bytes
Result using flatpak list:

jsfchan@DESKTOP-B72ROMI:~$ flatpak list
Name Application ID Version Branch Origin Installation
Nyxt engineer.atlas.Nyxt 2.2.4 master nyxt-origin system
Mesa …g.freedesktop.Platform.GL.default 21.3.9 21.08 flathub system
Mesa …g.freedesktop.Platform.GL.default 22.3.5 22.08 flathub system
Mesa (Extra) …g.freedesktop.Platform.GL.default 22.3.5 22.08-extra flathub system
openh264 org.freedesktop.Platform.openh264 2.1.0 2.0 flathub system
openh264 org.freedesktop.Platform.openh264 2.1.0 2.2.0 flathub system
GNOME Application Platform version 44 org.gnome.Platform 44 flathub system
GNOME Software Development Kit version… org.gnome.Sdk 42 flathub system

%%%%% Failure to run with the following message: %%%%%

jsfchan@DESKTOP-B72ROMI:~$ flatpak run engineer.atlas.Nyxt
error: Could not connect: No such file or directory

Dear sirs/madams, please kindly assist.


Dear sirs/madam,

One more comment is that the version no. is 2.2.4 instead of 3-pre-release-5.


I had similar problems under Ubuntu 22.10. I got a little farther: nyxt starts, but complains about a certificate error.
For now I have reverted back to use the flatpak for the previous Nyxt pre-release.

Dear sirs/madams, another update from me a novice user.

PS C:\WINDOWS\system32> wsl.exe --version
WSL version:
Kernel version:
WSLg version: 1.0.50
MSRDC version: 1.2.3770
Direct3D version: 1.608.2-61064218
DXCore version: 10.0.25131.1002-220531-1700.rs-onecore-base2-hyp
Windows version: 10.0.23419.1000

This morning, I had enabled the newly added SYSTEMD function of WSL by
sudo nano /etc/wsl.conf:


After shutdown and restart WSL, I can:

flatpak run engineer.atlas.Nyxt

@@@@@ But the following messages appeared: @@@@@

Nyxt version 3-pre-release-5
[09:17:50] Source location: #P"/usr/local/share/"
[09:17:50] Listening to socket: #P"/run/user/1000/nyxt/nyxt.socket"
[09:17:50] GTK extensions directory: #P"/usr/local/share/libraries/web-extensions/"

(nyxt:2): Gtk-CRITICAL **: 09:17:50.695: _gtk_css_lookup_resolve: assertion ‘(((extension ({ GTypeInstance __inst = (GTypeInstance) ((provider)); GType __t = ((_gtk_style_provider_private_get_type ())); gboolean __r; if (!__inst) __r = (0); else if (__inst->g_class && __inst->g_class->g_type == __t) __r = (!(0)); else __r = g_type_check_instance_is_a (__inst, __t); __r; }))))’ failed

(nyxt:2): GLib-GObject-CRITICAL **: 09:17:50.695: g_object_set_data_full: assertion ‘G_IS_OBJECT (object)’ failed

(nyxt:2): Gtk-ERROR **: 09:17:50.695: Can’t create a GtkStyleContext without a display connection
[09:17:50] Warning: Error in FFI method: internal error 165: NIL; args=NIL
[09:17:50] Warning: Error on separate thread: There is no applicable method for the generic function
when called with arguments
See also:
The ANSI Standard, Section 7.6.6

the screen frozen and Nyxt screen cannot display


Hi johan_widen,

I had also reverted back to pre-release-4 nyxt.flatpak.

But I got the same error messages.

Are you running the Microsoft WSL Ubuntu or standalone Ubuntu Linux ?

Dear all,

I had reverted back to pre-release-3 using Debian dpkg instead of flatpak.
Firstly I downloaded the nyxt_3_amd64.deb from github.com .
Secondly I needed to run: [ sudo apt-get install -f ] to resolve the lib dependency issues.

I can get the Nyxt running but with the following messages:

screen captured begin

You are using ASDF version 3.3.5 from
#P"/home/runner/common-lisp/asdf/asdf.asd" and have an older version of ASDF
(and older than 2.27 at that) registered at
#P"/home/runner/common-lisp/asdf/asdf.asd". Having an ASDF installed and
registered is the normal way of configuring ASDF to upgrade itself, and
having an old version registered is a configuration error. ASDF will ignore
this configured system rather than downgrade itself. In the future, you may
want to either: (a) upgrade this configured ASDF to a newer version, (b)
install a newer ASDF and register it in front of the former in your
configuration, or (c) uninstall or unregister this and any other old version
of ASDF from your configuration. Note that the older ASDF might be
registered implicitly through configuration inherited from your system
installation, in which case you might have to specify
:ignore-inherited-configuration in your in your
~/.config/common-lisp/source-registry.conf or other source-registry
configuration file, environment variable or lisp parameter. Indeed, a likely
offender is an obsolete version of the cl-asdf debian or ubuntu package,
that you might want to upgrade (if a recent enough version is available) or
else remove altogether (since most implementations ship with a recent asdf);
if you lack the system administration rights to upgrade or remove this
package, then you might indeed want to either install and register a more
recent version, or use :ignore-inherited-configuration to avoid registering
the old one. Please consult ASDF documentation and/or experts.

; compilation unit aborted
; caught 1 fatal ERROR condition
Nyxt version 3-pre-release-3
[15:46:10] Source location: #P"/usr/local/share/"
[15:46:11] Listening to socket: #P"/run/user/1000/nyxt/nyxt.socket"
[15:46:11] GTK extensions directory: #P"/usr/local/share/libraries/web-extensions/"
[15:46:11] GTK extensions directory: #P"/usr/local/share/libraries/web-extensions/"
[15:46:12] Loading #P"/home/jsfchan/.local/share/nyxt/history/default.lisp".
[15:46:12] History version “2.2.4” differs from current version “3-pre-release-3”
[15:46:12] Restoring 3 buffers from history.
[15:46:12] Loading #P"/home/jsfchan/.local/share/nyxt/auto-rules.lisp".

screen captured end

Please kindly advise how to fix the following issue as I cannot locate the file /home/runner/common-lisp/asdf/asdf.asd .

You are using ASDF version 3.3.5 from
#P"/home/runner/common-lisp/asdf/asdf.asd" and have an older version of ASDF
(and older than 2.27 at that) registered at

I’m pretty sure that this thread belongs to GitHub issues on Nyxt, because it’s a build failure. The forum is for ideas and discussions, not for bug reports :frowning:

Hi aartaka,

Thank you for your reminder.
I will check how to report this issue in GitHUB - Nyxt tomorrow.

I am running standalone Ubuntu linux

I now downloaded nyxt-3-source-with-submodules.tar.xz, unpacked it in a subdirectory,
cd to subdirectory, make all.
This built nyxt without any problems. Note though that I have sbcl installed and have built older nyxt versions in the same way.
I also built the web-extensions support. and doc. I have not done a make install, instead I made a symbolic link to the nyxt executable, and run it from the build directory:
cd ~/bin; ln -s …/Downloads/x1/nyxt

When I ran nyxt initially I got a lot of error messages, but they disappeared once I had moved my old ~/.config/nyxt out of the way.

Hi johan_widen,

Please kindly advise how to move old (e.g. 2.2.4) ~/.config/nyxt out of the way.

@JohnSF1, run rm -r ~/.config/nyxt.