Copy and Paste Errors

I’m having issues with the clipboard. If I right click and copy paste then it works. If I have something copied, then C-y will paste it just fine. But if I try and copy it with M-w (emacs-mode) then I get the following error.

Warning: Error on separate thread: Subprocess #<UIOP/LAUNCH-PROGRAM::PROCESS-INFO {1008159DC3}>
with command ("xclip" "-out" "-selection" "clipboard")
exited with error code 1

I’ve tried to search for it and all of the posts seem to be over 2 years old and deal with trivial-clipboard. I’m not sure if that’s still an issue after these years?

I’m running Arch Linux, running Nyxt/GI-GTK 3-pre-release-2-834-g5042a2bb4. Of course as I went to find this I tried it and it worked… but then restarted Nyxt and it didn’t work anymore. It seems if there is already something in the clipboard it will work fine, but not initially? I’m still pretty new to Nyxt so I’m not sure exactly where to look for more help.

Hmmm, I can reproduce this. Care to report on GitHub (so that we don’t forget about fixing trivial-clipboard (which is most probably the reason of the error) about this issue)?