Build from source issue (Ubuntu 18.04 based linux distro on Chromebook)

Background: on GalliumOS with SBCL 1.5.0, able to build from source with ‘make all’ using GTK, but when I run, I get the following. The program doesn’t crash, but also doesn’t do anything else useful:

$ ./nyxt
<INFO> [20:49:15] Listening to socket "/run/user/1000/nyxt/nyxt.socket".Nyxt version 2-pre-release-7-30-gc77ab93dWARNING: Changing meta-class of BROWSER from SB-KERNEL:UNKNOWN-TYPE to SB-KERNEL:STANDARD-CLASSOID.<WARN> [20:49:15] Warning: Error on GTK thead: The value #<SB-KERNEL:UNKNOWN-TYPE PROMPT-BUFFER> is not of type SB-KERNEL:CLASSOID

I was suggested to try at least SBCL 2.0.0. When I try to install SBCL 2.0.0 or above, I get this: $ sbcl --versionSBCL 1.5.0aryzach Downloads$ sh install.sh /usr/localm - Pastebin.com

with the relevant issue being this output:

’ $ sbcl --version`

sbcl: /lib/x86_64-linux-gnu/libc.so.6: version GLIBC_2.28’ not found (required by sbcl)`

Thoughts:

  • Does SBCL 2.* require libc6 version >= 2.28 ? GalliumOS only supports 2.27
  • Gallium package manager uses SBCL 1.4.5
  • Tried a VM. I’m currently on a Chromebook, and had trouble running other operating systems in the VM. I could continue down this path, but was running into issues, and any functionality was slow, so not an ideal dev environment regardless
  • I could get a new computer (and might need to soon), but I’d rather hold off if I’m able to

There may be other options, but I see three possible solutions:

  • Nyxt doesn’t require SBCL 2.*
  • SBCL 2.* doesn’t require libc6 version >= 2.28 and I’m able get SBCL 2.* on my Chromebook
  • I get a new computer

Hey, maybe of help: I solve my installation issues by installing via Guix. Have you tried that?

1 Like

We use quite a lot of SBCL 2.* features, so I’m not sure that suporting branch 1 would be easy. The option about requiring earlier versions is not feasible then.

Other options I can tell nothing about :frowning:

Using Guix, as suggested by Andrea, can be an option.

Thanks Andrea, Guix worked